sexta-feira, 12 de maio de 2017

Mikrotik - script to set channel list

Usem com cuidado, pois nem todos canais são permitidos em determinados países.
 #Script to set channel's in list.
#Will do both 10 and 20mhz in 5ghz

:global ifslink 5180,5750,5770,5790,5810,5830,5850,5870,5890
#Set 5ghx 20mhz scanlist
:global ifs5ghz 5390,5410,5430,5450,5470,5490,5510,5530,5550,5570,5590,5610,5630,5650,5670,5690
#set 5ghz 10 mhz scanlist
:global ifs2ghz 2409,2429,2414,2434,2419,2439,2424,2444,2449,2469,2454,2474,2459,2479,2464,2484
#set 2.4 ghz scanlist
:global band5ghz 5ghz-a/n
#possible values 5ghz-a  5ghz-a/n  5ghz-onlyn
:global band24ghz  2ghz-b/g/n
#possible values 2ghz-b  2ghz-b/g  2ghz-b/g/n  2ghz-onlyg  2ghz-onlyn

:global ifw5ghz20 20
:global ifw2ghz 10
:global ifw5ghz10 10


:foreach i in=$ifs5ghz do={/interface wireless channels add list=5ghz-10mhz frequency=$i width=$ifw5ghz10 band=$band5ghz } 
:foreach i in=$ifslink do={/interface wireless channels add list=5ghz-20mhz frequency=$i width=$ifw5ghz20 band=$band5ghz } 

#for 2,4ghz#
# :foreach i in=$ifs2ghz do={/interface wireless channels add list=2ghz-10mhz frequency=$i width=ifw2ghz band=band24ghz }

Reações:

0 comentários: