sexta-feira, 26 de fevereiro de 2016

Mikrotik - servidor hotspot com paginas de aviso

Configurando servidor MikroTik com Hotspot e páginas de aviso (atraso e bloqueio)




Tipologia da rede do MikroTik

Aqui usarei o seguinte:

ISP:
192.168.50.20/24

REDE:
192.168.1.1

MikroTik versão:
2.9.50

Note: Podem ser em outras também. 



Configurando os IPs, route e dns do MikroTik

Esta parte creio que todos já sabem, mas vamos dar um refresh, pois há alguns que estão começando agora.

Como costumo fazer, renomeio as interfaces:

/interface set ether1 name=internet comment="conexão com a internet"
/interface set ether2 name=network comment="conexão com os clientes"


Configurar os IPs:

/ip address add address=192.168.50.20/24 interface=internet
/ip address add address=192.168.1.1/24 interface=network


Configurar os DNS:

/ip dns set primary-dns=192.168.50.1
/ip dns static add name=192.168.1.1 address=192.168.1.1


Compartilhando a internet com a rede local

Esta etapa todos já sabem de cór:

/ip firewall nat add chain=src-nat src-address=192.168.1.0/24 action=masquerade



Configurando o web-proxy (opcional)



Como dito, esta configuração é opcional.

Configurar o servidor proxy:

/ip web-proxy set transparent-proxy=yes max-cache-size=40000000 cache-drive=system max-object-size=4096 port=3127 max-ram-cache-size=512000 enabled=yes

Listar qual endereço acessará o cache:

/ip web-proxy access add src-address=192.168.1.0/24 action=allow
/ip web-proxy access add action=deny


Bloquear acesso da internet com destino ao proxy:

/ip firewall filter add chain=input dst-address=192.168.1.1 protocol=tcp dst-port=3127 in-interface=internet action=drop

Redirecionar a rede para o proxy:

/ip firewall nat add chain=pre-hotspot src-address=192.168.1.0/24 protocol=tcp dst-port=80 action=redirect to-port=3127 




Criando o servidor dhcp para o servidor hotspot


Note: Se você estiver usando configuração de IP estático nos seus clientes, só precisará adicionar os IPs ao criar osusuários do servidor hotspot.

Criando nossa range de IPs:

/ip pool add name=pool ranges=192.168.1.2-192.168.1.254 next-pool=none 

Criando o servidor dhcp:

/ip dhcp-server add name=servidor-dhcp address-pool=pool interface=network
/ip dhcp-server network add address=192.168.1.0/24 dns-server=192.168.1.1 gateway=192.168.1.1


Servidor hotspot

Nesta etapa criaremos o servidor hotspot.

Configurar o perfil do nosso servidor:

/ip hotspot profile add name="config" hotspot-address=192.168.1.1 dns-name="192.168.1.1" html-directory=hotspot rate-limit="" http-proxy=0.0.0.0:0 smtp-server=0.0.0.0 login-by=mac,http-chap split-user-domain=no use-radius=no

Criar o servidor hotspot:

/ip hotspot add name=servidor-hotspot profile=config interface=network




Criando o perfil para cada situação

Aqui vamos criar o perfil para quem tem velocidade de 128k/80k (down/up), para quem está com mensalidade atrasada e para quem está bloqueado no sistema.

Para quem tem velocidade de 128k/80k:

/ip hotspot user profile add name=liberado address-pool=pool rate-limit="128k/80k" shared-users=1 idle-timeout=5m status-autorefresh=1m transparent-proxy=yes open-status-page=always advertise=no

Para quem está com mensalidade atrasada:

/ip hotspot user profile add name="Aviso" address-pool=pool idle-timeout=5m keepalive-timeout=2m status-autorefresh=1m shared-users=1 transparent-proxy=yes open-status-page=always advertise=yes advertise-url=aviso.html advertise-interval=20m advertise-timeout=15s

Para quem está bloqueado:

/ip hotspot user profile add name="Bloqueado" address-pool=pool idle-timeout=5m keepalive-timeout=2m status-autorefresh=1m shared-users=1 incoming-filter="input" outgoing-filter="output" transparent-proxy=yes open-status-page=always advertise=yes advertise-url=bloqueio.html advertise-interval=1s advertise-timeout=never 

Criando usuários e setando o perfil

Aqui vamos criar os usuários para logar no servidor hotspot e setar o perfil para ele de acordo com a situação em que ele se encontra.

Criando o usuário:

/ip hotspot user add name=raniel profile="situação do usuário" server=servidor-hotspot password=1234

Para mudar o usuário de perfil:

/ip hotspot user set raniel profile="situação do usuário"

Note: Em "situação do usuário" coloque o perfil adequado. 

Enviando as paginas de aviso.html e bloqueio.html para o Mikrotik

Depois de criar as páginas aviso.html e bloqueio.html, vamos enviá-las para o diretório hotspot do servidor MikroTik.

Note: Se já estiver com o servidor hotspot habilitado é preciso que esteja logado.

Com um cliente ftp, exemplo filezilla client, conecte no Mikrotik e envie as páginas e as imagens criadas para a pasta hotspot. 




fonte: http://eletronicainform.blogspot.com.br/2010/04/configurando-servidor-mikrotik-com.html
Reações:

0 comentários: