terça-feira, 13 de setembro de 2016

Mikrotik - Hotspot Aviso de manutenção



Olá pessoal neste post irei mostrar uma forma definitiva para mostrar uma tela de aviso ao cair o link no mikrotik, este script funciona apenas para quem usa hotspot. Antes de tudo você precisa renomear o nome do seu servidor hotspot e a profile que está sendo usada em seu servidor hotspot.
  1. Vá Ip/Hotspot/Servers e coloque o seguinte nome em seu servidor atual “hotspotServer”
  2. Agora vá em Ip/Hotspot/ServerProfiles e coloque o seguinte nome na sua profile “profileServer”
Feito isso, você já pode copiar e colar o script abaixo no seu terminal e pressione enter.
Esse código criará uma profile especifica para linkar a pasta que enviaremos para dentro de files. Não esqueça de alterar o ip para o seu usado no hotspot
1/ip hotspot profile
2add dns-name="" hotspot-address=10.5.50.1 html-directory=manutencao http-cookie-lifetime=3d http-proxy=0.0.0.0:0 login-by=cookie,http-chap name=manutencao rate-limit="" smtp-server=0.0.0.0 split-user-domain=no use-radius=no;/
Este aqui será o responsável por monitorar o link.
1/tool netwatch
2add comment="Monitora Link - Por Josenildo Lima" disabled=no down-script="/ip hotspot set [find name=hotspotServer] profile=manutencao;\r\
3\n:local users;\r\
4\n:foreach int in=[/ip hotspot user find ] do={ \r\
5\n:set users [/ip hotspot user get \$int name];\r\
6\n/ip hotspot active remove [/ip hotspot active find user=\$users];\r\
7\n/ip hotspot cookie remove [/ip hotspot cookie find user=\$users];\r\
8\n}\r\
9\n/log warning \"A CONEXO FOI REESTABELECIDA\";\r\
10\n" host=8.8.8.8 interval=10s timeout=1s up-script="/ip hotspot set [find name=hotspotServer] profile=\"profileServer\";\r\
11\n/log warning \"A CONEXO FOI REESTABELECIDA\";\r\
12\n";/
O próximo passo agora é copiar os arquivos para dentro de files,ela ficará lado a lado com a pasta hotspot do seu mikrotik, mas antes disso você precisa entrar com os dados do seu provedor.
No arquivo disponível para download no final deste post, dentro da pasta manutencao, tem um arquivo chamado dado.js
1var titulo = 'SISTEMA EM MANUTENÇÃO';
2var mensagem = 'Lamentamos o incoveniente, estamos trabalhando para melhorar nosso sistema.';
3var telefone = '(11) 1234-5678';
4var email = 'suporte@provedor.com';
Abra-o em seu editor preferido, e entre com suas informações. Feito isso, já pode enviar para dentro de files.
Para testar, corte a conexão do seu mk e veja o resultado!



fonte:
https://clubedomikrotik.com/aviso-de-manutencao-ao-cair-o-link-no-mikrotik/
Reações:

0 comentários: